Ethereum Mining


I recommend dwarfpool and their eth-proxy. I have had no issues with my 1 R9 280x card running on my home computer for about 2 weeks. Have been paid just over 6 ETH so far. I found the stats took a little while to register but shouldn’t have any problem if your use the proxy they provide with fall back options. Below is the basic script I am running to kick off my proxy and also start mining. Getting 20-25 MH with 1 R9 280x with stock settings.

start /min C:\eth-proxy\eth-proxy.exe
"%programfiles%\Ethereum 0.9.41\Release\ethminer.exe" --farm-recheck 200 --cl-local-work 256 --cl-global-work 8192 -G -F

Just wish I held onto my old 6 x R9 280x card rigs back when it was profitable mining litecoin :frowning:


Does using the proxy give you the 10/20% increase they advertise?

I’m running my single AMD 7950 which gives around 20MH. Have been mining since about mid-Feb.

I started on ethpool for 10 days when I got the full block reward (~5 eth).
I then tried out nanopool for around 3 weeks and made almost 8 eth there.
I’ve now been trying out dwarfpool for the last 3 days (without proxy) and results so far have been similar to nanopool, except with dwarf you have to wait until you’ve made at least 1 eth before payout.


the proxy’s success is by using a stratum protocol, this helps send work back and forth quicker than standard get-work, this is how the improved hashrate is achieved, it doesn’t make the GPU actually mine faster, it just improves due to better latency and quicker work swap


I use --cl-local-work 256 --cl-global-work 4096 on my 7950s. It’s all voodoo and other forms of black magic though :wink:

EDIT: I get 40-44MH from 2 x HD7950 @ the basic stock speeds (800MHz/1250MHz). I have them running stock because one of them kept going MIA with some ethereum mining packages (I’m in full tinker mode) which I think was related to the TdrDelay being set to the default 2secs. I’m soak testing to see if 8 secs improves things and then back to overclocking tests.


Yes I had read that. Might have to give it a go and compare results.


Not sure to be honest, when I read about it on dwarfpool they said it was better so I didn’t really try without it. I simplifies the setup anyway and the .conf file is already filled in with all the dwarfpool related settings and fail over pools so worth using just for that :slightly_smiling:


I played with that setting a little bit and found that the most consistent for me so stuck with it :slightly_smiling:


Yeah I’ve just been having a bit of a play without luck and have reverted back to without the stratum proxy for now… I think it’s because I have files on different drives (not c:) and it’s not reading the .conf file. I get an error about the wallet not being configured, then loads of json failures… :frowning:

I’ll have to investigate more tomorrow.


It shouldn’t matter where they are, it expects the .conf to be in the same directory as .exe, that is all. Does it work if you just run eth-proxy.exe without mining or any batch scripts at all? It should still show it has connected, you can then start the miner separately and it should work.

EDIT: For the above script I put in here to work you need the .bat to live in the eth-proxy directory otherwise it won’t work without some tweaking. I just put a shortcut to the .bat file where I wanted it.


Ok so I seem to have it running a bit better now after fixing some file location issues and I’m now getting lot’s of messages stating “NEW_JOB MAIN_POOL” but no shares are showing up on dwarfpool. More investigation required.

EDIT: Got it going now, had 2 copies of the batch file open and was editing the wrong one, sigh…


Nice work, you will see that message a lot with hopefully “eth_submitWork from ’ ’ accepted” fairly often too :slightly_smiling:


I just bought a XFX AMD Radeon R9 380X DD Black OC 4GB for £189 will this card do the trick?

My 3gb 7970 would not mine for some reason


The 380X will be fine although I think it’s just a tweaked 280X (different silicon though which may be more power efficient?).

When you say your 7970 would not mine - what errors/behaviour were you getting? It may not be any different for the 380X…


Thanks, well in the CMD it said not enough memory so then I tried CPU mining by removing the -G argument and that wouldn’t work either. Then I tried using the proxy miner and it would not even start up. So I downloaded The C++ Eth miner which created a DAG file when trying CPU mining but would not load up, just froze on me. Couldn’t get it to start using - G

It’s been pretty frustrating to be honest because the card I have is a 3GB and not that old so it should work fine, but it doesn’t. So I thought what the hell I’ll buy a new card and see what happens!


Your DAG file is probably corrupted , delete it and restart. Be patient take some time to rebuilt it.


Ok thanks I’ll give that a try, where is the DAG file usually saved to?


I’m running Win 7 , my file is in c:\users{user}\AppData\Local\Ethash


From the dwarfpool FAQ…

DAG files in OSX and Linux are here: ~/.ethash

DAG files in Windows are here: C:\Users___\AppData\Local\Ethash


Thanks guys, I’ll delete it and will give it another go, I’ll let you know how I get on.


That card should definitely work! My 2GB nVidia cards still do…

What OS are you using?