Ethereum Mining


#101

Windows 7, I know I can’t understand it myself… I’ll try to take some screen captures of the errors I get later tonight if I can, although that was whilst CPU mining, the CMD screen just flashed on and off when I tried mining with the card??? I am sure I used the correct command lines in the .config file and it was I the same directory as the .exe proxy program.

When I tried running it via CMD command lines, it said the card did not have enough memory. (I think it’s the card, can’t think what else I might be doing wrong)


#102

create a .bat file and add this in before the command

It should fix the 2GB problem


#103

I already tried that using the following: I saved the .Bat file to the same location as the .conf and .EXE file… What command should be in the .conf file?


#104

Hmmm, maybe try to just start a .bat file first? Add “pause” at the end of your batch commands - See below- this will halt your miner if there are errors so that you can read the error message in ethminer.

I am still waiting for my GPU’s so just created a .bat file to give it a go.

Using ethminer-0.9.41-genoil-1.0.6 (Windows build)

.bat file in the same folder as ethminer.exe

If you using

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1

You put the commands at the top AKA

Although on a windows machine you will be able to set the setx settings once off in CMD and it should be saved, no need to put it in a batch file. (might be wrong but that is how I have done it since litecoin days)

This works on my Laptop with a dedicated HD 7730 2GB GPU (did not even run the setx commands)


#105

Once that works you can always go back to trying the proxy and .config etc.


#106

Just a heads up, not entirely ethereum related: Dwarfpool is solo mining their own fork of expanse and have been for almost a day now… ever since the homestead code went active at block 200,000 (they seem to still be using the old wallet “frontier” version).

If you’re using Dwarfpool for ethereum you may want to be vigilant and make sure it’s configured correctly for any future wallet upgrades… I believe Ethereum is fine on there for now though.


#107

Thank you, I’ll give this a try when I get back home later this evening, I will let you know what happens. Thanks again.


#108

That script is only valid if using the eth proxy for dwarfpool and the .bat file is in the eth-proxy directory with the .conf & .exe


#109

Thanks Paul


#110

Received and tested today … DOA card. :frowning:
Motherboard didn’t boot when I put this card in it ( alone ). Tried a second motherboard. Same.
Got my BIOS reset and other fuzzy thing …

Seller say it was running great , of course.
I opened a case on Ebay. This is very annoying.


#111

i’ve got a 7970 with this problem, i’ll sell it to you and tell you it runs great, how much you paying for it? :stuck_out_tongue:

i really hate it when that happens


#112

Sorry to hear, I have 3 arriving today, can’t wait :smiley: they still have warranty left until June so gonna really push them.


#113

Must have been a day for it. My latest 7970 arrived yesterday and it’s totally unresponsive :frowning:


#114

I feel less alone. No more used card for me. Going brand new if I can get my money back.


#115

Nah I’m still too cheap for full price. Got a full refund. Paid in bitcoin & refunded in bitcoin same day I returned the card - no waiting 5+ days like I’d have had to if I’d paid by credit/debit card!! I even made a few sats on the difference in rates…

Decided on another 7950 to add to the collection instead of a 7970. Better value. Another one will be on order once I’ve earned a bit more from the ones I have…

Paul


#116

Mine 7970’s arrived, all 3 working, getting about 22-23Mhahs per card running everything on stock. will play around with undervolting etc this weekend, want to bring TDP down for each card.

Windows batch files run flawlessly, tried running 1 in Linux but having a bit of an issue with the command to point to dwarfpool.

Anyone mining on Linux?


#117

What problem are you having


#118

Got it sorted thanks, Had to change the repository location from where lubuntu downloads from. Seems the selected one had some dependencies missing. Working now. But thinking I might just reload with Windows instead.

New issue is remoting into the box with teamviewer etc not always loading up. Annoying so will rather stick to what I know.


#119

I’m playing with a proxy (currently testing out the nicehash fork) as I have a few different machines I can point on an ad-hoc basis when they aren’t being otherwise used. Works really well and I set -v 0 on ethminer so the rigs are pretty much silent (why waste energy printing out information nobody ever reads!).

All you need installed on the “slave” nodes is ethminer. You can even fall back to solo mining (only need to have rpc running on the proxy node) if the primary and secondary pools be unavailable.

.

The hash rates are pants because I’m in full tinker mode so they aren’t getting a chance :smiley:


#120

Ok so my brand new Rad R9 380x 4GB arrived, I installed in in my PC no problem, tried mining with it and guess what still the same error msg … "No GPU device with sufficient memory was found. Can’t GPU mine. Remove the -G argument

Any idea what I am doing wrong? This is my batch file, and is in the same folder as ethminer.exe program file.

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1

ethminer.exe -G -F http://eth-eu.dwarfpool.com:80/0x4D27AeEFFA55A76646DA9d233548B1923B1bB19d/ilan

pause